Hinweis für die Besucher

Dies ist nur eine Joomla! 4.0 Testseite in einem frühen Alpha-Stadium. Diese wird zu Test- und Demozwecken verwendet. Es werden lediglich verschiedene Textfragmente ohne irgendwelchen Zusammenhang gepostet. Falls du die aktuelle Joomla News-Page suchst, dann schaue mal hier nach.

Zur Joomla!Info Website Artikel zu Joomla! 4.0

Betreff:

Joomla! 4.0 Fragen, die in meinen Kursen und an den JUG Treffen immer wieder gestellt werden:

Wenn es der Stand der Entwicklung zulässt und die vorgesehenen Funktionen einigermassen stabil funktionieren. Aktuell sind wir noch in der Alpha-Phase. Da kann sich noch sehr viel ändern und Updates auf die nächst höhere Version sind mit Problemen verbunden und sind nicht gewährleistet. Sobald sich alle geplanten Funktionen im Core befinden (Feature Freeze) wird die Beta-Phase gestartet.
Wenn ich jetzt ganz fies bin, würde ich dir an dieser Stelle sagen: siehe bei Frage 1. Nein, im Ernst. Wenn wir Glück haben und alles so verläuft, wie es sich das Joomla! Production Team vorstellt, sollten wir bis Ende dieses Jahres 2019 eine erste Beta bekommen.
Wenn du heute eine neue Seite baust, die produktiv erreichbar sein soll, dann nimm eine aktuelle Joomla! 3.x. Sollte dann irgendwann in der Zukunft Joomla! 4.0 Stable erscheinen, kannst du sicher sein, dass Joomla! 3.x ab Erscheinungsdatum von Joomla! 4.0 noch weitere zwei Jahre Updates und Support-Fixes bekommen wird.
Ein Beispiel: Erscheint Joomla! 4.0 Stable am 01.09.2020, wirst du für Joomla! 3.x noch bis mindestens 31.08.2022 Sicherheits-Updates bekommen.
NEIN! Solltest du nur Core-Funktionen nutzen, wirst du aber mit einem relativ kleinen Aufwand die Seite aktualisieren können. Mit der Umstellung von Bootstrap 2 auf 4 wird wohl mit ziemlicher Sicherheit dein Template Schwierigkeiten machen. Ganz zu schweigen von den Erweiterungen, die erst auf die neue Version angepasst werden müssen. Da sind die Entwickler gefordert, ihre Erweiterungen entsprechend anzupassen. Aktuell kenne ich nur Akeeba Backup, dass unter Joomla! 4.0 schon fehlerfrei funktioniert. Weitere werden bestimmt bald folgen.
Eigentlich noch sehr wenige. Du kannst im JED (Joomla Extension Directory) nachschauen. Da gibt es ein Suchtag, dass mit «J4alpha» gekennzeichnet ist. Jedoch laufen nicht alle mit J4.0 gekennzeichneten Erweiterungen mit der Joomla! 4.x fehlerfrei. Ich habe einige davon getestet und muss sagen, dass viele davon nicht funktionieren. Ich würde vor jeder Installation einer neuen Erweiterung zuerst ein Backup machen.